2020 FJRiders.com Calendar Contest is underway! Vote Here!

2018 - How to check TPS

Tech section strictly for the FJR. Everything from oil changes & suspension setup's to removing sheep hair from hard to reach places on the bike so that your wife never finds out.
Post Reply
Canadian FJR
Squid
Posts: 49
Joined: Mon Sep 01, 2014 8:31 am
FJRModel: 2018 FJR-1300ES, 2003 Yamaha FJR-1300 (gone to a new home after 271,000 kms), 2001 Kawasaki KLR-650, 1997 Suzuki TL-1000s (Gone but not forgotten), 1976 Honda 400 Four
Location: Nova Scotia, Canada
x 16

2018 - How to check TPS

Post by Canadian FJR » Sat Sep 07, 2019 2:47 pm

I was able to check and replace the Throttle Position Sensor on my old 2003.

I do not know how to check it on my new 2018, and it looks like there may be two of them. One called the Throttle Sensor Assembly and the other one is called Accelerator Sensor Assembly.

During most initial cold starts, the bike fires up with a slight hesitation or burble. Almost like not firing on all four. Once it does fire, it goes through its cold (high) idle then settles to the norm. No other issues. Once warm, it works perfect.

A few details: The bike has 54,000 km on it. First big service has been completed. Valves are in spec, new plugs and TBS.


Any input would be appreciated.

Canadian FJR

User avatar
ionbeam
Contributor
Veteran
Posts: 1236
Joined: Mon Feb 04, 2013 7:14 am
FJRModel: '15ES in Low-Viz Assfault Gray
Location: Sandown, NH
x 237
x 1895

Re: 2018 - How to check TPS

Post by ionbeam » Sat Sep 07, 2019 4:09 pm

You are correct, there are two sensors, the TPS and accelerator sensor. For some reason the Gen III has been having some sensor failures. Fortunately, the failures have been the TPS because the accelerator sensor would require removing the throttle body to change it. When there was a problem with the earlier Gen III, the dealers were instructed to replace the entire throttle body assembly for TPS symptoms. Really. And wait half a year to get the replacement TB assembly.

Moving on... The TPS can be checked using an OBD II reader or the old school method using a DMM on the sensor and looking for voltage drop-outs. The TPS and accelerator sensors are not likely candidates to cause a cold start problem. The first, best tool to use for this is the OBD II reader. A properly trained technician should be able to data log sensors to find the root cause. (Are the plugs OK? Are the plug caps fully seated?)

Has this been going on long enough to be confident it isn't a gas fill issue? Have you run a tank or two with a FI injector/fuel system cleaner?

Don't let it sit long enough to get cold :lol:
wheatonFJR loved this

User avatar
bill lumberg
Contributor
Veteran
Posts: 827
Joined: Tue Jun 30, 2015 1:03 pm
FJRModel: 2018ES
x 1013
x 806

Re: 2018 - How to check TPS

Post by bill lumberg » Sat Sep 07, 2019 6:30 pm

Listen to ionbeam....

On a separate note- my 2018 wanders all over the place on startup. Sound like it’s fighting over and under to hold idle. Gets a little better when it’s warmed up. But it stands out. I’m not going to worry about it unless it changes. Almost 27,000 miles.
ionbeam wrote:
Sat Sep 07, 2019 4:09 pm
You are correct, there are two sensors, the TPS and accelerator sensor. For some reason the Gen III has been having some sensor failures. Fortunately, the failures have been the TPS because the accelerator sensor would require removing the throttle body to change it. When there was a problem with the earlier Gen III, the dealers were instructed to replace the entire throttle body assembly for TPS symptoms. Really. And wait half a year to get the replacement TB assembly.

Moving on... The TPS can be checked using an OBD II reader or the old school method using a DMM on the sensor and looking for voltage drop-outs. The TPS and accelerator sensors are not likely candidates to cause a cold start problem. The first, best tool to use for this is the OBD II reader. A properly trained technician should be able to data log sensors to find the root cause. (Are the plugs OK? Are the plug caps fully seated?)

Has this been going on long enough to be confident it isn't a gas fill issue? Have you run a tank or two with a FI injector/fuel system cleaner?

Don't let it sit long enough to get cold :lol:
No commercials. No dictators.
www.fjriders.com

IBA #69560

Canadian FJR
Squid
Posts: 49
Joined: Mon Sep 01, 2014 8:31 am
FJRModel: 2018 FJR-1300ES, 2003 Yamaha FJR-1300 (gone to a new home after 271,000 kms), 2001 Kawasaki KLR-650, 1997 Suzuki TL-1000s (Gone but not forgotten), 1976 Honda 400 Four
Location: Nova Scotia, Canada
x 16

Re: 2018 - How to check TPS

Post by Canadian FJR » Sat Sep 07, 2019 8:36 pm

Plugs are good and caps are seated. Many tanks and I did try some injection cleaner. I’ll chat with my local shop tech and see if he can shed some light.

Thanks for the input,
Canadian FJR

User avatar
dcumpian
Squid
Posts: 42
Joined: Mon Sep 24, 2018 7:16 am
FJRModel: 2018 FJR1300A
Location: King William, VA
x 57
x 24

Re: 2018 - How to check TPS

Post by dcumpian » Mon Sep 09, 2019 8:53 am

bill lumberg wrote:
Sat Sep 07, 2019 6:30 pm
Listen to ionbeam....

On a separate note- my 2018 wanders all over the place on startup. Sound like it’s fighting over and under to hold idle. Gets a little better when it’s warmed up. But it stands out. I’m not going to worry about it unless it changes. Almost 27,000 miles.
ionbeam wrote:
Sat Sep 07, 2019 4:09 pm
You are correct, there are two sensors, the TPS and accelerator sensor. For some reason the Gen III has been having some sensor failures. Fortunately, the failures have been the TPS because the accelerator sensor would require removing the throttle body to change it. When there was a problem with the earlier Gen III, the dealers were instructed to replace the entire throttle body assembly for TPS symptoms. Really. And wait half a year to get the replacement TB assembly.

Moving on... The TPS can be checked using an OBD II reader or the old school method using a DMM on the sensor and looking for voltage drop-outs. The TPS and accelerator sensors are not likely candidates to cause a cold start problem. The first, best tool to use for this is the OBD II reader. A properly trained technician should be able to data log sensors to find the root cause. (Are the plugs OK? Are the plug caps fully seated?)

Has this been going on long enough to be confident it isn't a gas fill issue? Have you run a tank or two with a FI injector/fuel system cleaner?

Don't let it sit long enough to get cold :lol:
Mine too. It worried me at first, but it runs fine, accelerates fine, and never stalls or anything like that, so I'm just going to assume it's normal.

Dan
bill lumberg loved this

Post Reply